Wissens- und Unwissenswertes

Alles, was die Welt (nicht) wissen will ;-)

Plugin arbeitet wohl nicht korrekt

01.09.09 (Allgemein)

Ich verwende auf meinem Heim-PC Firefox 3.5.2. Auf puhbaer.eupuhbaer.eu habe ich ein Plugin (Internet Explorer 6 Upgrade), das den Browser der Besucher erkennt und bei Internet Explorer 6 ein Fenster öffnet, man solle seinen Browser aktualisieren, da dieser veraltet ist.
Jedoch bringt das Plugin dzt. ein Paar Fehler. Mit dem aktuellen Firefox scheint es Probleme zu geben. Ich möchte das Plugin jedoch nicht deaktivieren, da wohl die Anzahl der veralteten Browser höher als die False-Positive-Quote sein wird…

Update:

Da sich die False-Positives häufen (nun auch auf dem Rechner meiner Freundin (Vista, Firefox 3.5.2)), habe ich nun auf der Homepage des Herstellers 😉 einen Kommentar hinterlassen. Da diese Webseite auf portugiesisch ist, tue ich mir naturgemäß schwer, da ich kein portugiesisch kann! C’est la vie… Bin auf eine Antwort gespannt…

Ein Kommentar

  • 1
    Marcelo Rodrigo:

    Hello Mayrhofer,
    Thank you for visiting!

    I checked your problem, and my sincere apologies, but I could not reproduce the same problem here.
    I use Firefox as default browser too (best browser, no?) on my notebook and visiting your site using FF, plugin did not show me the warning as if I were browsing in IE6.

    Well, a explanation of how it works:
    The plugin has a double check to determine which is the User’s browser, here we go:

    First, a regex checks if the variable $ _SERVER[ ‚HTTP_USER_AGENT‘ ] contains the „msie“ string, if it is this part of the plugin to the next phase
    If the phase 1 back positive, it will print the code that calls the pop-up beginning with , which should only be triggered by IE6 (or earlier)

    I asked for a screenshot of your site and does not occur to activate the plugin using FF: http://browsershots.org/screenshots/483fee5eb03119ede6efa1067c285829/
    Can you send me what the contents of the variable $ _SERVER [ ‚HTTP_USER_AGENT‘] are displayed in your FF?

    I appreciate your willingness to help and thank you for reporting this issue, I hope to fix it with your help 😉

Kommentar schreiben

XHTML: Sie können diese Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>